SlushEngine power issue


Hi! I’m new to SlushEngine, I got SlushEngine a month ago with RBX1 kit.
Because of printing problem, I’ve finished now.
But the real problem was SlushEngine board. When I turn on the power, then died immediately like power shorted.
So I checked below image’s power terminal. they were all shorted.

So nothing worked! By the way power adapter was fine, 24v.
What should I check?



Could you show a picture on how you connected your power adapter to the Slush?

Thank you,


Thank you for answer!
I wired like below picture. GND to left, + to right.


That’s exactly how mine was wired so I can’t help much here. Possible it’s a problem with the power supply? Or a defective board.


Board is problem. I double checked the power supply it’s fine.
Thank you for your answer


Mine too died a while ago, they send me another one and one of the output died for no reason, this is frustrating.


What was your contact method?
I used contact form on main webpage, but they did’t answer me yet.


I don’t think they replay to anyone. Never even got all the parts for our robot. No answer. Time to use someone else.


Yes, I placed an order like 10 days ago and up to now, no updates. Hello is anybody there?


Will you be sending it out then.


Frank another issue I am having with the robot is I can run only one motor at a time. If I run more than one motor, it will not run ether. put an O’scope on it and I can run any more just not two. Any help would be greatly appreciated.


Steven, I am not from Roboteurs. I also placed an order online on their site, but I have not heard of them since.


This is looking like a scam Robot from reading posts. No one getting answers.


No Scam. They started as a kickstarter project 2015. But there is not much of forum or email support (none). So I wonder if I will receive anything ever.


Maybe I just have to wait a little longer.


I received my robot parts a couple weeks ago and only ordered about a month ago (July 12) but I’m still finishing up the printing. So far only one printed model is not correct for fitting a bushing (Base Gear).

I think perhaps the issue is that they can’t full time the site this project.


I dont know. Another 8 days gone by and order status remains unfulfilled. I sent several emails, but no reply.


I got a response on their FB page. Try that.


Good Idea. It was one of my first clicks on the roboteurs page to go to FB, but the Link on the Page goes to 404 on FB (Page does not exist), so I searched and found which works.